import Foundation
let pattern = #"^"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
"Cliente1\\Rem\\COB0111111.REM.txt"
"Cliente1\\Rem\\23123123.REM.txt"
"Cliente1\\OK\\COB02222222.REM.txt"
"Cliente1\\Ret\\COB0613062019.REM.txt"
"COB0613062019.REM.txt"
"Cliente2\\COB0613062019.REM.txt"
"Cliente2\\Rem\\COB0633333.REM.txt"
"Cliente2\\Rem\\pasta2\\COB02123123.REM.txt"
"Cliente2\\Bla\\Rem\\COB0613062019.REM.txt"
"Cliente1\\COB0613062019.REM.txt"
"Rem\\COB0613062019.REM.txt"
"Rem"
"Cliente3"
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)