import re
regex = re.compile(r"^", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("\"Cliente1\\\\Rem\\\\COB0111111.REM.txt\"\n"
"\"Cliente1\\\\Rem\\\\23123123.REM.txt\" \n"
"\"Cliente1\\\\OK\\\\COB02222222.REM.txt\" \n"
"\"Cliente1\\\\Ret\\\\COB0613062019.REM.txt\"\n"
"\"COB0613062019.REM.txt\" \n"
"\"Cliente2\\\\COB0613062019.REM.txt\"\n"
"\"Cliente2\\\\Rem\\\\COB0633333.REM.txt\"\n"
"\"Cliente2\\\\Rem\\\\pasta2\\\\COB02123123.REM.txt\"\n"
"\"Cliente2\\\\Bla\\\\Rem\\\\COB0613062019.REM.txt\"\n"
"\"Cliente1\\\\COB0613062019.REM.txt\"\n"
"\"Rem\\\\COB0613062019.REM.txt\" \n"
"\"Rem\"\n"
"\"Cliente3\"")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")