#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)https?://(?:www\.)?t(?:elegram)?.me/[a-zA-Z0-9_-]*\/?"
Local $sString = "http://www.t.me/test1" & @CRLF & _
"http://telegram.me/test2" & @CRLF & _
"http://www.telegram.me/test3" & @CRLF & _
"http://telegram.me/test4" & @CRLF & _
"https://www.t.me/test5" & @CRLF & _
"https://telegram.me/test6" & @CRLF & _
"https://www.telegram.me/test7" & @CRLF & _
"https://telegram.me/test8"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")