import Foundation
let pattern = #"https?://(?:www\.)?t(?:elegram)?.me/[a-zA-Z0-9_-]*\/?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
http://www.t.me/test1
http://telegram.me/test2
http://www.telegram.me/test3
http://telegram.me/test4
https://www.t.me/test5
https://telegram.me/test6
https://www.telegram.me/test7
https://telegram.me/test8
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)