use strict;
my $str = 'http://www.t.me/test1
http://telegram.me/test2
http://www.telegram.me/test3
http://telegram.me/test4
https://www.t.me/test5
https://telegram.me/test6
https://www.telegram.me/test7
https://telegram.me/test8';
my $regex = qr/https?://(?:www\.)?t(?:elegram)?.me/[a-zA-Z0-9_-]*\/?/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}