import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "https?://(?:www\\.)?t(?:elegram)?.me/[a-zA-Z0-9_-]*\\/?";
final String string = "http://www.t.me/test1\n"
+ "http://telegram.me/test2\n"
+ "http://www.telegram.me/test3\n"
+ "http://telegram.me/test4\n"
+ "https://www.t.me/test5\n"
+ "https://telegram.me/test6\n"
+ "https://www.telegram.me/test7\n"
+ "https://telegram.me/test8";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}