import re
regex = re.compile(r'https?://(?:www\.)?t(?:elegram)?.me/[a-zA-Z0-9_-]*\/?', flags=re.MULTILINE)
test_str = ("http://www.t.me/test1\n"
"http://telegram.me/test2\n"
"http://www.telegram.me/test3\n"
"http://telegram.me/test4\n"
"https://www.t.me/test5\n"
"https://telegram.me/test6\n"
"https://www.telegram.me/test7\n"
"https://telegram.me/test8")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")