const regex = new RegExp('https?://(?:www\\.)?t(?:elegram)?.me/[a-zA-Z0-9_-]*\\/?', 'gm')
const str = `http://www.t.me/test1
http://telegram.me/test2
http://www.telegram.me/test3
http://telegram.me/test4
https://www.t.me/test5
https://telegram.me/test6
https://www.telegram.me/test7
https://telegram.me/test8`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}