using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"https?://(?:www\.)?t(?:elegram)?.me/[a-zA-Z0-9_-]*\/?";
string input = @"http://www.t.me/test1
http://telegram.me/test2
http://www.telegram.me/test3
http://telegram.me/test4
https://www.t.me/test5
https://telegram.me/test6
https://www.telegram.me/test7
https://telegram.me/test8";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}