#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^deploy-file-\d+_[\w-_.]+\d+.log$"
Local $sString = "deploy-file-181011105609_Glassfish-server_Glassfish_server_2018.11.006_server-2018.11.006.log" & @CRLF & _
"deploy-file-181205082159_Glassfish-server_server-2019.log"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")