using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^deploy-file-\d+_[\w-_.]+\d+.log$";
string input = @"deploy-file-181011105609_Glassfish-server_Glassfish_server_2018.11.006_server-2018.11.006.log
deploy-file-181205082159_Glassfish-server_server-2019.log";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}