$re = '/^deploy-file-\d+_[\w-_.]+\d+.log$/m';
$str = 'deploy-file-181011105609_Glassfish-server_Glassfish_server_2018.11.006_server-2018.11.006.log
deploy-file-181205082159_Glassfish-server_server-2019.log';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);