const regex = /^deploy-file-\d+_[\w-_.]+\d+.log$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^deploy-file-\\d+_[\\w-_.]+\\d+.log$', 'gm')
const str = `deploy-file-181011105609_Glassfish-server_Glassfish_server_2018.11.006_server-2018.11.006.log
deploy-file-181205082159_Glassfish-server_server-2019.log`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}