// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^deploy-file-\d+_[\w-_.]+\d+.log$").unwrap();
let string = "deploy-file-181011105609_Glassfish-server_Glassfish_server_2018.11.006_server-2018.11.006.log
deploy-file-181205082159_Glassfish-server_server-2019.log";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}