import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^deploy-file-\\d+_[\\w-_.]+\\d+.log$";
final String string = "deploy-file-181011105609_Glassfish-server_Glassfish_server_2018.11.006_server-2018.11.006.log\n"
+ "deploy-file-181205082159_Glassfish-server_server-2019.log";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}