re = /^deploy-file-\d+_[\w-_.]+\d+.log$/m
str = 'deploy-file-181011105609_Glassfish-server_Glassfish_server_2018.11.006_server-2018.11.006.log
deploy-file-181205082159_Glassfish-server_server-2019.log'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end