# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\.([A-Za-z])/\.\L$1/gm;t' <<< "[$.Carpool[0].NoofSeats], [$.Carpool[1].NoofSeats]
[$.Carpool[0].NoofSeats], [$.carpool[1].noofSeats]"