// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\.([A-Za-z])").unwrap();
let string = "[$.Carpool[0].NoofSeats], [$.Carpool[1].NoofSeats]
[$.Carpool[0].NoofSeats], [$.carpool[1].noofSeats]";
let substitution = "\\.\\L$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}