package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\.([A-Za-z])`)
var str = `[$.Carpool[0].NoofSeats], [$.Carpool[1].NoofSeats]
[$.Carpool[0].NoofSeats], [$.carpool[1].noofSeats]`
var substitution = "\.\L$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}