use strict;
my $str = '[$.Carpool[0].NoofSeats], [$.Carpool[1].NoofSeats]
[$.Carpool[0].NoofSeats], [$.carpool[1].noofSeats]';
my $regex = qr/\.([A-Za-z])/mp;
my $subst = '\\.\\L$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";