#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\.([A-Za-z])"
Local $sString = "[$.Carpool[0].NoofSeats], [$.Carpool[1].NoofSeats]" & @CRLF & _
"[$.Carpool[0].NoofSeats], [$.carpool[1].noofSeats]"
Local $sSubst = "\.\L$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)