$re = '/\.([A-Za-z])/m';
$str = '[$.Carpool[0].NoofSeats], [$.Carpool[1].NoofSeats]
[$.Carpool[0].NoofSeats], [$.carpool[1].noofSeats]';
$subst = "\.\L$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;