import Foundation
let pattern = #"\.([A-Za-z])"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
[$.Carpool[0].NoofSeats], [$.Carpool[1].NoofSeats]
[$.Carpool[0].NoofSeats], [$.carpool[1].noofSeats]
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\.\L$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)