# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^=separator=.*(?:\R(?!(?:=separator=|.*?\bunwantedKeyword\b)).*)*\R.*?\bunwantedKeyword\b.*\R*//gm;t' <<< "=separator=
data
unwantedKeyword
data
=separator=
data
wantedKeyword
data
=separator=
data
unwantedKeyword
data
=separator=
data
wantedKeyword
data
=separator="