re = /^=separator=.*(?:\R(?!(?:=separator=|.*?\bunwantedKeyword\b)).*)*\R.*?\bunwantedKeyword\b.*\R*/m
str = '=separator=
data
unwantedKeyword
data
=separator=
data
wantedKeyword
data
=separator=
data
unwantedKeyword
data
=separator=
data
wantedKeyword
data
=separator='
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result