use strict;
my $str = '=separator=
data
unwantedKeyword
data
=separator=
data
wantedKeyword
data
=separator=
data
unwantedKeyword
data
=separator=
data
wantedKeyword
data
=separator=';
my $regex = qr/^=separator=.*(?:\R(?!(?:=separator=|.*?\bunwantedKeyword\b)).*)*\R.*?\bunwantedKeyword\b.*\R*/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";