$re = '/^=separator=.*(?:\R(?!(?:=separator=|.*?\bunwantedKeyword\b)).*)*\R.*?\bunwantedKeyword\b.*\R*/m';
$str = '=separator=
data
unwantedKeyword
data
=separator=
data
wantedKeyword
data
=separator=
data
unwantedKeyword
data
=separator=
data
wantedKeyword
data
=separator=';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;