#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^=separator=.*(?:\R(?!(?:=separator=|.*?\bunwantedKeyword\b)).*)*\R.*?\bunwantedKeyword\b.*\R*"
Local $sString = "=separator=" & @CRLF & _
"data" & @CRLF & _
"unwantedKeyword" & @CRLF & _
"data" & @CRLF & _
"=separator=" & @CRLF & _
"data" & @CRLF & _
"wantedKeyword" & @CRLF & _
"data" & @CRLF & _
"=separator=" & @CRLF & _
"data" & @CRLF & _
"unwantedKeyword" & @CRLF & _
"data" & @CRLF & _
"=separator=" & @CRLF & _
"data" & @CRLF & _
"wantedKeyword" & @CRLF & _
"data" & @CRLF & _
"=separator="
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)