using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!<div>)(.*)$";
string input = @"<div>Lorem ipsum.</div> - эту строку не надо;
Lorem ipsum. - эту строку надо;
<li>Lorem ipsum.</li> - и эту строку надо;
<div>Lorem ipsum.</div> - эту не надо.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}