$re = '/^(?!<div>)(.*)$/m';
$str = '<div>Lorem ipsum.</div> - эту строку не надо;
Lorem ipsum. - эту строку надо;
<li>Lorem ipsum.</li> - и эту строку надо;
<div>Lorem ipsum.</div> - эту не надо.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);