import re
regex = re.compile(r"^(?!<div>)(.*)$", flags=re.MULTILINE)
test_str = ("<div>Lorem ipsum.</div> - эту строку не надо;\n"
"Lorem ipsum. - эту строку надо;\n"
"<li>Lorem ipsum.</li> - и эту строку надо;\n"
"<div>Lorem ipsum.</div> - эту не надо.")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")