re = /^(?!<div>)(.*)$/m
str = '<div>Lorem ipsum.</div> - эту строку не надо;
Lorem ipsum. - эту строку надо;
<li>Lorem ipsum.</li> - и эту строку надо;
<div>Lorem ipsum.</div> - эту не надо.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end