import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!<div>)(.*)$";
final String string = "<div>Lorem ipsum.</div> - эту строку не надо;\n"
+ "Lorem ipsum. - эту строку надо;\n"
+ "<li>Lorem ipsum.</li> - и эту строку надо;\n"
+ "<div>Lorem ipsum.</div> - эту не надо.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}