#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?i).*\K(?>(?<=school of )\w+|\b\w++(?= school))"
Local $sString = "Engineering School" & @CRLF & _
"Medical school" & @CRLF & _
"The School of Science" & @CRLF & _
"High School of science" & @CRLF & _
""
Local $sSubst = "[X]"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)