$re = '/.*\K(?>(?<=school of )\w+|\b\w++(?= school))/i';
$str = 'Engineering School
Medical school
The School of Science
High School of science
';
$subst = "[X]";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;