use strict;
my $str = 'Engineering School
Medical school
The School of Science
High School of science
';
my $regex = qr/.*\K(?>(?<=school of )\w+|\b\w++(?= school))/ip;
my $subst = '[X]';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";