#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)how (does|do|can) (i|he|they)"
Local $sString = "I need assistance, how can I help my friend?" & @CRLF & _
"" & @CRLF & _
"How can I help my friend?" & @CRLF & _
"" & @CRLF & _
"My friend is in need of help, how can I?"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")