$re = '/how (does|do|can) (i|he|they)/i';
$str = 'I need assistance, how can I help my friend?
How can I help my friend?
My friend is in need of help, how can I?';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);