using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"how (does|do|can) (i|he|they)";
string input = @"I need assistance, how can I help my friend?
How can I help my friend?
My friend is in need of help, how can I?";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}