// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)how (does|do|can) (i|he|they)").unwrap();
let string = "I need assistance, how can I help my friend?
How can I help my friend?
My friend is in need of help, how can I?";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}