re = /how (does|do|can) (i|he|they)/i
str = 'I need assistance, how can I help my friend?
How can I help my friend?
My friend is in need of help, how can I?'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end