const regex = /how (does|do|can) (i|he|they)/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('how (does|do|can) (i|he|they)', 'gi')
const str = `I need assistance, how can I help my friend?
How can I help my friend?
My friend is in need of help, how can I?`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}