package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)how (does|do|can) (i|he|they)`)
var str = `I need assistance, how can I help my friend?
How can I help my friend?
My friend is in need of help, how can I?`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}