#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)>\K(?=[0.]*[1-9])\d+(?:\.\d+)?+\h+Dollar(?=<)"
Local $sString = ">0 Dollar</span" & @CRLF & _
">0.01 Dollar</span" & @CRLF & _
">0.00 Dollar</span " & @CRLF & _
">50.00 Dollar</span" & @CRLF & _
">50.00 Test</span" & @CRLF & _
">1 Test</span" & @CRLF & _
">0 Test</span" & @CRLF & _
"" & @CRLF & _
"It does work for >0 Dollar</span >0.00 Dollar</span >0.01 Dollar</span >50.00 Dollar</span" & @CRLF & _
"" & @CRLF & _
">50.0 Dollar</span" & @CRLF & _
">50. Dollar</span" & @CRLF & _
">0.0 Dollar</span" & @CRLF & _
">00000.00 Dollar</span" & @CRLF & _
">00 Dollar</span" & @CRLF & _
">50.91 Dollar</span" & @CRLF & _
">50.00001234 Dollar</span"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")