const regex = />\K(?=[0.]*[1-9])\d+(?:\.\d+)?+\h+Dollar(?=<)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('>\\K(?=[0.]*[1-9])\\d+(?:\\.\\d+)?+\\h+Dollar(?=<)', 'gm')
const str = `>0 Dollar</span
>0.01 Dollar</span
>0.00 Dollar</span
>50.00 Dollar</span
>50.00 Test</span
>1 Test</span
>0 Test</span
It does work for >0 Dollar</span >0.00 Dollar</span >0.01 Dollar</span >50.00 Dollar</span
>50.0 Dollar</span
>50. Dollar</span
>0.0 Dollar</span
>00000.00 Dollar</span
>00 Dollar</span
>50.91 Dollar</span
>50.00001234 Dollar</span`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}