use strict;
my $str = '>0 Dollar</span
>0.01 Dollar</span
>0.00 Dollar</span
>50.00 Dollar</span
>50.00 Test</span
>1 Test</span
>0 Test</span
It does work for >0 Dollar</span >0.00 Dollar</span >0.01 Dollar</span >50.00 Dollar</span
>50.0 Dollar</span
>50. Dollar</span
>0.0 Dollar</span
>00000.00 Dollar</span
>00 Dollar</span
>50.91 Dollar</span
>50.00001234 Dollar</span';
my $regex = qr/>\K(?=[0.]*[1-9])\d+(?:\.\d+)?+\h+Dollar(?=<)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}