import Foundation
let pattern = #">\K(?=[0.]*[1-9])\d+(?:\.\d+)?+\h+Dollar(?=<)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
>0 Dollar</span
>0.01 Dollar</span
>0.00 Dollar</span
>50.00 Dollar</span
>50.00 Test</span
>1 Test</span
>0 Test</span
It does work for >0 Dollar</span >0.00 Dollar</span >0.01 Dollar</span >50.00 Dollar</span
>50.0 Dollar</span
>50. Dollar</span
>0.0 Dollar</span
>00000.00 Dollar</span
>00 Dollar</span
>50.91 Dollar</span
>50.00001234 Dollar</span
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)