import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ">\\K(?=[0.]*[1-9])\\d+(?:\\.\\d+)?+\\h+Dollar(?=<)";
final String string = ">0 Dollar</span\n"
+ ">0.01 Dollar</span\n"
+ ">0.00 Dollar</span \n"
+ ">50.00 Dollar</span\n"
+ ">50.00 Test</span\n"
+ ">1 Test</span\n"
+ ">0 Test</span\n\n"
+ "It does work for >0 Dollar</span >0.00 Dollar</span >0.01 Dollar</span >50.00 Dollar</span\n\n"
+ ">50.0 Dollar</span\n"
+ ">50. Dollar</span\n"
+ ">0.0 Dollar</span\n"
+ ">00000.00 Dollar</span\n"
+ ">00 Dollar</span\n"
+ ">50.91 Dollar</span\n"
+ ">50.00001234 Dollar</span";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}