re = />\K(?=[0.]*[1-9])\d+(?:\.\d+)?+\h+Dollar(?=<)/m
str = '>0 Dollar</span
>0.01 Dollar</span
>0.00 Dollar</span
>50.00 Dollar</span
>50.00 Test</span
>1 Test</span
>0 Test</span
It does work for >0 Dollar</span >0.00 Dollar</span >0.01 Dollar</span >50.00 Dollar</span
>50.0 Dollar</span
>50. Dollar</span
>0.0 Dollar</span
>00000.00 Dollar</span
>00 Dollar</span
>50.91 Dollar</span
>50.00001234 Dollar</span'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end