# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r">\K(?=[0.]*[1-9])\d+(?:\.\d+)?+\h+Dollar(?=<)"
test_str = (">0 Dollar</span\n"
">0.01 Dollar</span\n"
">0.00 Dollar</span \n"
">50.00 Dollar</span\n"
">50.00 Test</span\n"
">1 Test</span\n"
">0 Test</span\n\n"
"It does work for >0 Dollar</span >0.00 Dollar</span >0.01 Dollar</span >50.00 Dollar</span\n\n"
">50.0 Dollar</span\n"
">50. Dollar</span\n"
">0.0 Dollar</span\n"
">00000.00 Dollar</span\n"
">00 Dollar</span\n"
">50.91 Dollar</span\n"
">50.00001234 Dollar</span")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.